Mikrotik блокировка сайта с layer7-protocol

Предысловие

В связи с последними новостями в мире игр, а именно увлечении разработчиков игр в слежении за пользователями, была необходимость в блокировке некоторых ресурсов, а так как инфраструктура настроена со статическими ip, включая запросы к DNS на 8.8.8.8, то естественно подмены ДНС в таком случае не целесообразно. В итоге была блокировка на уровне запроса к днс по определенным маскам уже известных серверов получателей инфо о пользователях.

Итак. работаю я с железкой RouterBOARD 3011UiAS

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
/ip firewall layer7-protocol
add name=redshell regexp="^.+(redshell).*\$"
add name=treasuredata regexp="^.+(treasuredata).*\$"

/ip firewall mangle
add action=mark-connection chain=prerouting connection-mark=no-mark dst-port=\
53 layer7-protocol=redshell new-connection-mark=redshell_conn \
passthrough=yes protocol=udp
add action=mark-connection chain=prerouting connection-mark=no-mark dst-port=\
53 layer7-protocol=treasuredata new-connection-mark=treasuredata_conn \
passthrough=yes protocol=udp
add action=mark-packet chain=prerouting connection-mark=redshell_conn \
new-packet-mark=redshell_packet
add action=mark-packet chain=prerouting connection-mark=treasuredata_conn \
new-packet-mark=treasuredata_packet

/ip firewall filter
add action=drop chain=forward packet-mark=redshell_packet
add action=drop chain=forward packet-mark=treasuredata_packet

 

на этом все. после данного действия ПК не может определить адрес домена.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *